Got a weird one. I had a test collection of http web monitors that needed to be changed to https. I changed the URIs, and although they validated correctly, the website address didn’t update within the monitors – it was still trying to check the old URIs.

I then deleted the old web app monitor and added a new one – my issue is it no longer completely creates the monitor. I’ve tried this a few times and it seems to only create a ‘Web Application Availability Monitoring Test Collection’ that never goes green; it doesn’t create the ‘Web App Monitoring Resource Pool’.

Bizarrely, i did manage to create one for Twitter, which went all the way through to being a monitored web app with a resource pool etc, but it doesn’t work for any URI that I actually want to monitor!

Any ideas or pointers where to look? I’ve tried creating the web app monitors in a different MP, with different watcher nodes with no success. I’m going to take another look at URLGenie, but it would be nice to work this one out just for my own sanity!

Peter Aston selected answer
    • I had almost the same problem. I could not update my monitors they never got saved. I have the solution somewehere in my email. I will search now. Somewhere in my mind I think I had to create a new MP and save the monitors there.
    • Pretty sure this is to do with stale objects still in the database(s). There's a PowerShell cmdlet that will do this or some SQL queries. Neither should be taken lightly. Remove-SCOMDisabledClassInstance - Look into it
    • I've run Remove-SCOMDisabledClassInstance previously to clear something else up - now I'm wondering if that's what's broken it!