0
Jelly 2.86K Rep.

I’m having trouble getting the SCOM Installation to pick up a SQL instance behind a SQL AlwaysOn listener.

The setup logs show some generic errors

Error: :Error opening SQL connection.: Threw Exception.Type: System.Data.SqlClient.SqlException, Exception Error Code: 0x80131904, Exception.Message: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 – The wait operation timed out.)

I can point the wizard directly to the SQL instances successfully, but using the listener name with or without the instance “SC2016” simply does not work.

More info:

  • SQL servers have two NICs, one for the cluster (18.18.18.x), one for the VM (172.x.x.x)
  • I’ve ensured the port is set correctly as 1433
  • SQL Server 2016, with SCOM 2016, running on a Server 2016 machine (upgrades!)
  • The installation wizard is using my account, which I’ve confirmed has login/create rights on both SQL instances
  • I’ve tried failing over the AG in case one node was the issue
  • Name resolution works from the SCOM MS
  • Firewalls are off on both networks

Annoyingly, I swear I ran into this a year or so ago but cannot for the life of me figure out what I’ve missed 🙁

timharris answered
    • I have to setup a new SCOM lab in the next few days so I'll try this and see if I get the same results
    • Awesome! Thanks Liam. In order to progress my lab, I've pointed SCOM at a single SQL server and will be migrating as per some articles I've found online 🙂 I'm intrigued to see if you find similar results though 🙂