Cisco UCS MP - Custom Label - Advance properties

I am trying to build a UCS dahsboard, and looking to add a list of server firmware.

I can see the values in SCOM

and also from within Squared Up drill down

So I am trying to add this value to a custom label within a status dashboard

using {{Name}} | {{FirmwareVersion}} , but the display is coming up blank. Have also tried ticking the ‘load extended properties’ box, but still no joy.

What would be the best way to get the actual label of these values?


1 Like

To find the property variable names for an object, you can use the Operations Manager Shell to query SCOM:

Get-SCOMMonitoringObject -id <insert_object_id> | fl
This will list out all of the extended properties. The Squared Up custom labelling does not require the [Class.Name] part of the variable.

Example for finding Logical Processors:

To use any extended properties you will have to check the ‘load extended properties’ box. Also be careful about getting capitalisation correct.

(sorry for posting as an answer, instead of a comment, but couldn't get pictures added to comment)

So I managed to get the properties list


but the custom label is still showing blank

Worth noting, I have to use {{Name}} and not {{DisplayName}}, as expected.

Try this…

Click on sort
Then custom
And then look and see how the properties are written in there. That should show you the syntax that’s expected for the object. Then use that syntax in Label…if its different.

Thanks Blake, I tried you suggestion,

but you’ll see that this differs from the results for

Get-SCOMMonitoringObject -id <insert_object_id> | fl

If I try to use any of the fields from the powershell outage, I don’t get any values displayed

maybe I’m using the wrong scope.?

try this:




Have a look at “Sort” -> “More” -> “load extended properties (longer load times)”.

You will find a dropdown with all available Properties there.

I’ve edited my post, it sould work like this.

nope, still blank :frowning:

Wayyyyy back when this was around, I believe there was an issue pulling all properties for objects. It’s now resolved and in v3 you can pull any properties required. Hopefully, the friendly support folk sorted you out!

Woa. Where did you get that UCS information? I need to monitor that in my environment. Is there a MP available?



thanks for the suggestion, but same issue , blank values