Citrix Logon Simulator - Configuration error

I have created a SquaredUp Dashboard to view the State of the Citrix Logon Simulator. Now if i want to execute the task "View last logon result" i receive the following error:

Get-Content : Der Pfad "C:\Monitoring\Citrix\Log\CITRIX-DESKTOP (Citrix 
Simulated Login)\sflauncher.log" kann nicht gefunden werden, da er nicht 
vorhanden ist.
In fact the path "C:\Monitoring\Citrix\Log\CITRIX-DESKTOP (Citrix Simulated Login)\sflauncher.log" does not exist because it is C:\Monitoring\Citrix\LOGS\..... This is the default path that is created by the script.

So the configuration of the task is not correct as it refers to Log instead of Logs. Is there a way to solve this? Maybe an update of the MP?

This MP is hosted on Github. I would raise an issue there for it to be resolved by the developer:

Open Community.Citrix.LogonSimulator.mpb with MP Author - editor. Save as XML file. Open XML file with Notepad and modify line:

Get-Content $ConfigurationPath\Log$TestName\sflauncher.log</ScriptBody>


Get-Content $ConfigurationPath\Logs$TestName\sflauncher.log</ScriptBody>


Import as new management pack (before this delete the original MP).

Now the task works fine.

I tried this same thing, changed the path, saved as xml, reimported, and still doesn’t work.

Task results

The task completed succesfully. The output is shown below:

Get-Content : Cannot find path 'C:\Monitoring\Citrix\Logs\ 
Citrix\sflauncher.log' because it does not exist.
At line:3 char:1
+ Get-Content $ConfigurationPath\Logs\$TestName\sflauncher.log }
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (C:\Monitoring\C...\sflauncher.l 
   og:String) [Get-Content], ItemNotFoundException
    + FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.GetCo 

ok I resolved this by manually creating the sflauncher.log file. However, it still doesn’t write anything to it and the monitor still goes bad yet I can run the Test-Citrix script manually and it launches and closes the app without issue. This MP seems very buggy. If anyone has been able to get this to work successfully please let me know.