Google Analytics reauthorization

I was able to GA to work but for some reason, after a time period, I have to reauthorize under settings. Is this a problem with GA or Squared Up? Is there a fix?

I am having same issue, I need to reauthorize Google Analytics every hour. I thought they fixed this issue in new SquaredUp version 5.1.1 but it doesn’t looks like.

Any one has any solution for this issue? I would really appreciate if you can provide me any solution for this issue.

interesting you mention this re-authorisation issue. I am having a similar issue with Veeam APIs, I know support is looking into this issue. It looks like the token is refreshed, but the new token isn’t used :frowning:

@yogesh.patel just a quick update on this.

Turns out it does actually work, Google is just extremely picky about how it issues tokens that actually work… :slight_smile: If you could try the following and post back that would be really great.

All you need to do in this case is add two parameters to the authorization URL.

access_type=offline
include_granted_scopes=true

So your authorization URL in the providers page should be;

https://accounts.google.com/o/oauth2/v2/auth?access_type=offline&include_granted_scopes=true

When you save the provider, we’ll automatically update that URL further to include the contents of the scope box. If you’re following our KB, the scope should be;

https://www.googleapis.com/auth/analytics.readonly

I tried this and its not working, i still need to authorize every hour.

Hmmm, that’s strange. Mine has been running without break for a couple of days now.

Can you confirm all your settings are exactly the same?

Base URL
https://www.googleapis.com/

Authorization URL
https://accounts.google.com/o/oauth2/v2/auth?access_type=offline&include_granted_scopes=true

Token URL
https://oauth2.googleapis.com/token

Scope
https://www.googleapis.com/auth/analytics.readonly

My token URL was different (https://www.googleapis.com/oauth2/v4/token).
I just replaced with same as yours, i will let you know how this goes.

Thanks. I’ll check the docs for the token URL you’ve listed and if yours is from a later version of the API, I’ll update my stuff to match and make sure it still all works. Hope to hear some good news soon

Appreciate you checking and feeding back :trophy:

Its not working, I still need to perform authorization. :frowning: