How to configure TLS/SSL (HTTPS)

Hi there,

I recently downloaded the free version and set out to install it on a freshly installed and fully patched domain joined Windows Server 2019. I have not installed or enabled anything other than Microsoft/Security updates, prior to executing squaredup-5.2.1-6654-DS.exe

The installation went fine. A reboot was required. Following the installation, I confirmed that the web console loads just fine and I am able to navigate and initiate all sorts of functions. I then noticed that the web console was running http and not https, so I searched for a guide to enable https and found the following: How to configure TLS/SSL (HTTPS) – SquaredUp Support

I followed all three steps in the guide but was unable to get it to work. When I navigate to htt p://localhost/ or htt p://fqdn/ or http s://localhost/ or http s://fqdn/ I get the IIS blue landing page. Even if I try to browse the website from another computer on the network using a combination of http or https pointing to IP address or hostname or fqdn, I still only get the IIS blue landing page.

The only thing that works is the redirect to https.

Any ideas what I am missing here?


I’ve just been through all the steps and screenshots for the third time and confirm that everything has been done as described. Does anyone have any input?

Sounds like you’ve installed the application to an application pool rather than website (I’m no IIS expert so apologies if I’m getting the terminology wrong). I suspect if you use https to call the default pool (ie hxxps://fqdn/SquaredUpv5) you would get to your deployment.


So on this page of the installer if you edit the URL (I think) you should get the option to specify if you want to install this to the application pool or the root of the website.

Either option works, I’ve always followed the default of using an application pool and not the root personally. However if you do want the root of the website to go to the application pool you would have to put in a redirect/rewrite (I can never remember which is which) from the root to the application pool as described here.

Hi guy,

You were spot on. I followed the guide and added a second URL Rewrite rule “Root Hit Redirect” as described, and it now works as expected.

Thanks a bunch for your help!

1 Like