How To Stop Date from being formatted in UNIX time

In a PowerShell Grid tile, I have a pscustomobject with a datetime type property in the script result columns view (see top of pic). Then on the grid result, the display is in UNIX time (see bottom of pic). I have tried different tricks like re-casting it as datetime and forcing it to local TZ. Not sure what I’m doing wrong.

I even created a new tile to test my own sanity:

Hi Tony,

SquaredUp is recognizing that as a DateTime type and converts it to something that it understands. As long as the type remains the same it needs to do that conversion.

The easiest way of dealing with it is by converting it in the column using mustache and the timeago function. This is covered loosely in the documentation here:

The doc is written for custom labels, but the same basic principle should apply to columns as well. I think you just need to go into the columns and apply the transformation to the value if memory serves me.

Another less flexible option is to convert it to a string before you send it back, but this may cause other issues like impacting sortability.