IPConfig Data On Demand Task

I’ve added a data on demand task to the Network perspective to run ipconfig. If I create this on a 2012 server then it works, but doesn’t run when looking at a 2016 server. If I edit the perspective on a 2016 server then it works, but not on 2012! Ideally, I’d like one Network perspective that would run ipconfig regardless of OS; or do I have to create OS specific perspectives? I’ve got version of the DoD management pack.

This it the error I get when it tries to run the DoD task. Any ideas?

System.InvalidOperationException: The task cannot be executed against the object(s) because the target of the task does not match any of the classes of the object. at Microsoft.EnterpriseManagement.Runtime.TaskRuntimeManagement.ValidateTaskTargetsInternal[T](IEnumerable`1 targets, ManagementPackTask task, EnterpriseManagementGroup enterpriseManagementGroup) at Microsoft.EnterpriseManagement.Runtime.TaskRuntimeManagement.SubmitTask(EnterpriseManagementObject instance, ManagementPackTask task, TaskConfiguration configuration, TaskStatusChangeCallback callback) at SquaredUp.Connector.ScomTask.ScomTaskController.ExecuteTask(ManagementGroup mg, EnterpriseManagementObject target, ManagementPackTask task, TaskConfiguration taskConfiguration) at SquaredUp.Connector.ScomTask.ScomTaskController.<>c__DisplayClass7_0.<Execute>b__0()

I’ve worked around it by creating a PS task to run ‘ipconfig’ and then embedded that as a Data on Demand task on the default Network perspective. That seems to be Windows OS version agnostic.

Quick question; what, specifically, have you scoped the Perspective to?

I think the default scope is Windows Server, I’ve also tried Windows Computer.

I thought I’d cracked it with a custom PS task to run Get-NetIPConfiguration - but it looks like that won’t work on 2008 server sigh

Happy days :slight_smile: You can have the pleasure of marking your own answer as the correct one.