Issue with Top N Performance Bar

I have a metric that is collecting every 15 minutes, which I display on a performance graph and a Top N bar graph, but when I select hourly resolution and average the value it doesn’t work. I get the same value if I select Min, Max or Avg, on both Hourly and Daily Resolution. Am I missing something obvious here?

We are running version 3.3 and SCOM 2016.


Edit: I have found this happens with all our metrics.

Due to the way Squared Up calculates the size of the line in the bar graph it is usually recommended for metrics with a fixed upper value, e.g. percentages.

Without some magic, Squared Up will not know what the min/max values of a metric are, so you can add this to the JSON.

The Performance Bar Tile, by default, will only show the following display options, even if you’re not using a %-based metric;

“display”: {
“range”: “percentage”,
“label”: “auto”

But if you paste in the equivalent block from a Sparklines Tile where a custom range has been set, you’ll see all the variables and will be able to fine tune, for example;

“display”: {
“range”: “custom”,
“height”: 200,
“label”: “auto”,
“rangemin”: 0,
“rangemax”: 30,
“showKey”: “”

Hi Jelly, Cheers for that information. I am using percentages for my metrics at the moment, and have tried your comments to modify the JSON directly but I am still getting inaccurate aggregates of the data. It’s not how much is shown on the bar but the values pulled by squared up. They are being aggregated incorrectly. For example, I have a metric that is over 12 hours 12% max, 2.5% min, 8% Average, but when I put that into the graph with hourly or daily aggregates I get an average of 31.3%, or a minimum of 31.3% or a maximum of 31.3%.

Any further information would be greatly appreciated.

Hey All,

Thank you for your help, SquaredUP has acknowledged its a bug and is looking into it.

Love the community here, keep up the good work.