Management Pack Class not Found - Services and Server Role Health

Not sure what the classes this management pack is scoped to for “Server Role Health” and “Services”. I get error “An object of class ManagementPackClass with ID <GUID> was not found.”. Can only assume this was hard coded to a 2012R2 class?

I’m in a pure Server 2016 environment. Have created a new “Server Role Health” scoped to “Active Directory Domain Controller Computer Role”, but unsure what class has been used for “Services”?

If it is the AD Topology Health Status you are refering to it is scoped to the class “object” and the id of the object “Active Directory Topology Root”.

Run this command to get the id:

Get-SCOMClass -Name “Microsoft.Windows.Server.AD.Container” | select id

Haven't errors but all Active Directory dashboards are empty.

Criteria for AD Topology Health Status (object ID) dashboard doesn’t match with real ID from SCOM

PS C:&gt; Get-SCOMMonitoringObject -DisplayName “Active Directory Topology Root” |select id



All other AD dashboards can’t find group for scoping

P.S. Active Directory 2012 R2

ADDS MP Download Microsoft System Center Management Pack for ADDS from Official Microsoft Download Center

1 Like

I got my dashboard pack to NOT work now =)

If I remove all Active directory MP:s like the ones for “2008 or higher”. And removed all management packs containing “Active directory” name . Like “base class”.
The ones that came from this MP: Download Active Directory Domain Services Management Pack for System Center - Svenska from Official Microsoft Download Center

I then reimported the MP from this URL that only contains 2012, 2012 R2 and 2016

Then the ID for topology root changes to the one Alex had.

PS C:\admin> get-scomclass | Where-Object {$_.displayName -like “topology root”}

DisplayName Name ManagementPackName Id
———– —- —————— —
Active Directory Topology Root Microsoft.Windows.Server.AD… Microsoft.Windows.Server.AD… 2e9…

So the dashboard pack is built on the MP:s that contains Active directory 2008. If you install those the dashboard pack will work. It has to be rebuilt to support the 2012=<

This is a working filter when you only have the newest management pack installed. I guess you can tweak it a bit by changing the group from all windows computers to something else that contains Domain controllers of all versions from 2012 to 2016.

Had manually fixed it. You can choose "AD Domain Controller Group (Microsoft Windows Server 2012 R2" group. Also, don't forget to check timeframe for each dashboard

My apologies I was actually referring to the Domain Controller Perspective. There are two tiles here: Server Role Health (which I have fixed), and “Services”. The ID referred to for Services is ‘c8472479-f7c5-815f-18f0-87b6990e50ff’.

Interestingly the Active Directory Dashboard was also empty (as shown in Alex’ post). I updated the class ID to ‘2e99e65e-ba92-05b6-88a2-858831aad96d’, (powershell returned this ID for me also) but it is coming back as unmonitored. further investigation required.

I’m not sure which management pack you are refering to? Do you have the latest version?
On the Active directory dashboard pack that you can download I only have “AD Topology Health Status” and “server health” no services?

Chris - If you can send us the ID (this isn’t unique in your environment, as IDs from sealed MPs are hashed against the MP name, which is why all the SQUP dashboards and perspectives can be used by all), then we can try and see which MP it belongs in :slight_smile:

Strange thing… I tried to download the MP that you linked to and it seems to be a bit newer than the one I have installed versus
But after I downloaded it and try to install it I get an error:

Active Directory Server Domain Member (Monitoring) could not be imported.

If any management packs in the Import list are dependent on this management pack, the installation of the dependent management packs will fail.

Verification failed with 1 errors:

Error 1:
Found error in 2|Microsoft.Windows.Server.AD.DomainMemberMonitoring||Microsoft.Windows.Server.AD.DomainMemberMonitoring|| with message:
Could not load management pack [ID=Microsoft.Windows.Server.AD.Class.Library, KeyToken=31bf3856ad364e35, Version=]. The management pack was not found in the store.
: Version mismatch. The management pack ([Microsoft.Windows.Server.AD.Class.Library, 31bf3856ad364e35,]) requested from the database was version but the actual version available is

Can it be some bug in the newest management pack that causes the error you get?
My ID for the object matches the one stated in the criteria.

@jelly… Now it is up to you :smiley:

The Domain controller group 201X will work if all servers you monitor are at the same level. We have several active directory domains and some are 2012 R2 and other 2016 so then you have to target the class of Domain controller role instead.
You also have to target the role if you like us have domain controllers at different levels (2012 R2 and 2016) during upgrades.