Metric label formatting

I have added an SQL counter to my dashboard. The counter is in KB so the value is 9 744 410 aka 9,4 GB
But when I add that to a dashboard. The metric label messes up the values.
It defaults to bytes which gives the value of 9,4 MB. If I select megabytes I get 9,4TB. and if I select custom I can add KB and then get 9.4M KB which is kind of correct. But I want 9,4 GB.

Is there any way to fix that via the JSON-code?

When bytes, megabytes or seconds are selected SquaredUp will ‘scale up’ the label to MB, GB, minutes or hours as appropriate. When using the preconfigured options SquaredUp will also convert very small or large values which would normally be displayed as m, µ, k or M into the selected (or upscaled) metric. See Understanding the figures on Performance graphs

When selecting “other” all you are doing is adding the text to the view.

This one needs a feature request to add the KB option.

1 Like

Feature request sent =)
I also suggested the option to use custom labels in a more advanced way.
Eg. {{value}}/1024 GB

1 Like