New install of 1801 possible DW connectivity issue

Hi all,

New, clean install. DBA used default instance. During my first Management Server install I included mssql as the instance name in the setup wizard for OpsDB and DW. This resulted in my Management Servers not being monitored due to being unable to connect to the DB. I found the resolution here:

I altered configservice.config to drop the instance, after which all servers turned monitored and healthy. I figured I would have an issue somewhere with my DW as well although cannot find a config file pointing to the instance?

I am having event ID errors on my Primary Management Server 10801 Discovery Data couldn’t be inserted into the database. DataAccessLayer Warning Event ID 33333 and opsmgr sdk service error 26319, an exception was thrown while processing getdatawarehousestoredprocedureresult

Looks to me like I have a DataWarehouse issue?!? DBA does not want to setup a new SQL server for me.

I researched moving the Datawarehouse in attempt to find connection keys. What I have found points to the reg key, HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Operations Manager\3.0\Setup\DataWarehouseDBServerName

Under which both values for databaseservername, and datawarehousedbservername currently have the instance name included. Should I try to delete the instance names?

Is their a way to re provision the primary mgt servers connection to the dw?


1 Like

The steps described in the following link worked for me when faced with a similar scenario –


1 Like

Basically just go with procedure of moving DW Warehouse and just browse through all the locations there (Reg, files and DB itself).

If it is the default instance then you do not need to specify the instance name.

There are more details here -

As Rem says; it is basically the same as moving the DW.



Did you check
Still valid with 1801, just adjust the paths. There’s more than just the registry, some config files need to be updated as well. There’s also a document above it with the info to do the same with the DB.
I checked on my 1801s (which were upgrades), the xxxServerName just contain the servers FQDN (as I too am connecting the the default instances)

Thank you. I have updated the config files for the opsdb and left out the instance. There are no dw configs in the config file that I see? Within the registry paths for the obs db and the dw in your setup, do you have the instance names and port? Ex scomdbsrv\mssql,1443?

Keep instance name as in doc or remove instance name due to it being default mssql?

Whenever the instance is a default one and you haven’t provided any name during installation - remove instance name and leave it blank.