Replace Management Server SCOM 2016

I’m getting my SCOM2016 Management Group on to supported server OS in order to inplace upgrade to SCOM2022. I’ve already done 5 management servers by powering them off and bringing up a new VM with the same name and IP but up to date OS, then re-installing SCOM2016 to add them to the Management Group. It’s been a while since I did them and today I thought I’d tackle the last one, having spent last week making sure that the Gateways pointing at it could failover to another Management Server.

I stupidly shut down the old management server and deleted it’s AD object so that the new VM could be deployed, but I forgot to failover the agents that were reporting to it. Nevermind, I thought, I expect they’ll come back when I get the Management Server installed - but that’s where I’m hitting problems. I’ve got as far as the ‘configure the operational database’ screen.

Previously I couldn’t get the server and instance name to discover with the error:
“Error: :GetRemoteOSVersion(): Threw Exception.Type: System.UnauthorizedAccessException, Exception Error Code: 0x80070005, Exception.Message: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))”,
but I’ve got past that now - now the issue is that I can’t select the OperationsManager database in order to move on through the wizard. Anyone been here before and got any ideas!

I’m thinking that “Always: :Database OperationsManager already has the current machine listed; this would enter Disaster Recovery mode, which is not currently supported.” is the reason, but I can’t find any trace of the previous management server.

These errors are also in the logs:

“Error: :Sql error: 16. Error: 2812. Error Message: Could not find stored procedure ‘p_MOMManagementGroupInfoSelect’.
[17:07:14]: Info: :Info:isOMDatabase: Read did not return true. The MG is missing. This is not OM DB
[17:07:14]: Info: :Info:Using DB command timeout = 1800 seconds.
[17:07:14]: Error: :DB operations failed with SQL error 2812: Could not find stored procedure ‘p_MOMManagementGroupInfoSelect’.
: Threw Exception.Type: System.Data.SqlClient.SqlException, Exception Error Code: 0x80131904, Exception.Message: Could not find stored procedure ‘p_MOMManagementGroupInfoSelect’.”

Bizarrely, if i install a scom agent on this server then 200 orphaned agents suddenly light up in SCOM, but there’s still no trace of this management server so that I could fail them over to another one!

Edit to add that I’m running the installer as the SQL service account that is in admins group on management server and SQL server and has SA


I think I’ve fixed it! The few things I could find online all mentioned making sure that the previous agent wasn’t still in the console. Using SquaredUp I was able to see that the server was still in the VADA map for the SCOM Management Group. I removed it from there, and also used the SCOM console Discovered Inventory to find a mention of it under ‘Health Service Watcher (Management Server)’. I put that in maintenance mode for 5 mins. Then I did a Remove-SCOMDisabledClassInstance and tried the install again, and it’s gone straight through. Happy days.

1 Like