Scom - mp snmp

I have been using the new SCOM 2016 SNMP_MPGenerator to write MP’s for various network devices. I wrote the first MP to discover some IOD values and this worked well. I then went further to make a few changes then re-imported the MP (Each time I changed the MP Version) and still this worked well

For some reason after changing a MP more than 3 times the discovery stops working for the IOD I want to monitor?

I have tried several things like increasing the MP Version, Removing the network device and re-adding it etc. I guess if I leave this till tomorrow morning the discovery would run again over night?

Can anyone advise how to force a Discovery for a Particular MP in my case a bespoke MP for a SNMP discover network device.

2 Likes

To trigger a re-run of a discovery, you can follow the below steps:

1. In the SCOM Console select the Monitoring panel.

2. On the left-hand side, under Operations Manager, then Management Server, select Management Servers State.

3. In the Management Server State section select any of your Management Servers.

4. In the Tasks pane (right-hand side), find and select Trigger On Demand Discovery.

5. You will need to provide overrides for the TargetInstanceId and the DiscoveryId. The first of these is the SCOM ID for the object that the discovery targets, the latter is the SCOM ID of the Discovery.

Screenshot-2016-11-22-23.49.32.png

These can be obtained via the Operations Manager Shell, e.g. Get-SCOMClassInstance to find the object, and Get-SCOMDiscovery. You’ll need to enter them as an override surrounded by {} brackets, e.g. {711b2e47-8459-d6f2-5c83-034c96f12671}.

Hope that helps, let me know if you have any issues.

1 Like

Hi ClarkD

Thank you for the detailed answer you have provided however could I ask for a generic example as I keep getting this error :frowning:

DISCOVERY_NOT_FOUND

Can you try setting the overrides without the {} braces - part of me thinks they’re needed, but now I’m not so sure… Alternatively, can you check that the discovery is not disabled anywhere - I think that causes the issue too.

My colleague pointed me towards his blog which contains more info: https://matthewlong.wordpress.com/2013/01/24/scom-2012-manually-triggering-a-discovery-via-the-scom-console-on-demand-discovery/

No still not working - Have you got an example that works on your environment with the “Trigger on demand discovery”?

What does your MP target? Are you sure you have the correct IDs for the target object and discovery object?

The MP is targeting an SNMP device (UPS) that is discovered via SNMP – I’m not confident that I’m using the correct ID’s as I’m not sure what value to pass to Get-SCOMClass and Get-SCOMClassInstance hence why I want to try it first with something generic then try it on my MP