SCOM Reporting broken

My SCOM Reporting console is blank, I'm not sure when this happened as I don't go in there very often. I still get scheduled reports, and I can still see Report Tasks in Alert views for example. I'm just unable to create or edit reports. Any ideas? Do I have to reinstall Reporting?

It’s worth checking:

  • Console -> Administration->Settings -> Reporting - Check if the url points to correct path ...../ReportServer and\or if it's pointing to correct protocol: https or http
  • go to the same URL and check if you can find a data source named "Data Warehouse Main".

This looks similar to something I saw once before. Mine happened when upgrading to 1801. I remember I opened a case with MS for it. I have changed jobs since then though so I can not go back and look at the solution so I am working from memory. If my memory is right I think I had to reinstall the reporting module

To answer my own question, this was caused by a firewall between my SCOM console and the Reporting Server. D’oh!

Anything in the event log? Try accessing the console on another machine, if it works there, then try clearing your cache ( Worth checking the reporting instance is up and running also (Windows service on the DW server)

Sorry, should have added that to original post - nothing obvious that I can see, clearing cache and running from another machine also has same result. Reporting is up and running, and can browse to the Reports URIs and see content.