SNMP Device discovery

I want to discover a couple of snmp devices. I entered the FQDN in the discovery wizard, but they all came with the ip-adress in the network devices list. How can I resolve this problem, I want them with the FQDN listed?
Thanks, Luc

Hi Luc,

I had this issue. In my case, the PTR/reverse lookup DNS records were missing. Only the A/forward lookup records existed. After adding the PTR records, the FQDN was shown in SCOM.

If you already completed the discovery process and have the devices in SCOM with the IPs, you will have to remove them and run the discovery again after adding the PTR records. They won’t update their names if/when the PTR records are created.

This blog post might help too: Thoughts on Azure, OMS & SCOM: Hey SCOM! Why Are The Display Names Of My Monitored Network Devices IP Addresses?!


What I did, IIRC, is put the FQDN in the LMHost file on the Management server or Gateway I was using for the discovery/monitoring. When I rediscovered them (they had the ip-address initially in the network devices list like yours), It came up with the FQDN

Hi Ervia and Steve, I’ve checked the DNS and there is everything OK, I have an A record and a PTR record in the reverse lookup zone. I’ve also tried with adding it to the local host file. I found these steps for the discovery on an article on the internet:

  • Loopback IP
  • sysName
  • Public IP
  • Private IP
  • SNMP Agent IP
    The sysName in the MIB is set to the ip-address, but that I cannot change. I think normally it should be work with the dns set correct? Or is there some other setting?
    Regards, Luc