[SOLVED] Error with criteria

Hi, I have some issue creating a dashboard containing all instances of a class that have a specific pattern in name. I tried in powershell and this is working:

Get-SCOMClass -DisplayName “HPE OneView Proliant Server” | Get-SCOMClassInstance | Where-Object { $_.DisplayName -like “ILOCZ*” }

But, when it comes to a new tile, using this criteria:

displayname like “ILOCZ%”

results in error:

The property displayname is not valid for the given criteria.

How is this possible ? The property is existing in this class:

DisplayName : ILOCZJ6060C5Y.mydomain.net

Thanks for help

Hi Dimitri

I believe those property names are case-sensitive, and also the criteria string needs to be enclosed in single quotes. If you try this, does it work?

DisplayName LIKE 'ILOCZ%'


No, I already tried (because for me too it was case sensitive) but nothing changed.
Thanks :slight_smile:

BUT it was the single quote :smiley:
Thanks, I did not think at all to use them. True that sometimes 4 eyes see better than 2 !

Great! Glad to help :grinning:

1 Like