WMI is unhealthy

Since upgrading to SCOM 2016 UR3 I’ve got 7 agents out of 720 reporting as:

‘WMI is unhealthy; the WMI health monitor tried to run the WMI query “select * from win32_operatingsystem” and encountered a WMI error’.

I’ve followed the resolution steps but they’ve not made a difference. Has anyone else experienced this? These agents have all been upgraded to 2016 UR3 since this issue first manifested; they originally displayed the alert when the agents were 2012 R2 UR3 with the SCOM infrastructure at 2016 UR3.

1 Like

We had this same issue with a few of our agents and it was an SPN issue. After we corrected the SPN’s the agents reported healthy.


we have the same issue. You upgraded from 2012 R2 right?

The problem here is, that the monitor is rewirtten for 2016 in powershell and got a problem with the command “get-ciminstance” in combination with a registerd http SPN.

Atm there is just an workarround.

Just look at the following thread in technet:


The problem is that they wrote the WMI monitor in powershell for 2016. They opted to use remoting to get WMI information even if the script was running locally on the agent, so this is not needed and creates SPN issues for certain configurations.

Therefore I rewrote the monitors without this dependence on remoting. Can find the MP here:


I am in communication with MS to get this fixed in a future UR update.


Thanks Morten, just found and applied your MP while you were answering this - alerts are closing as I type!

Morton to the rescue! Thanks for marking this as solved also astonpa - This will help other users find the answer they are looking for!